27 Haziran 2014 Cuma

Başka Excel Dosyasından otomatik not çekmek

Öğrenci Bilgi Sistemine tek tek not yazmak yerine Excel dosyası ile otomatik not yükleyin.
ÖBS size notları girebileceğiniz sınıf listesi verir. Excel formatındadır. Bunun içine notları otomatik çekebilirseniz tek tek not girmenize gerek kalmayacaktır.

Sınav okuyucu program size notların olduğu Excel dosyası verir. Orada numaralı sıralanma olsa bile, hatalı kodlamalar nedeniyle, sınava girmeyen öğrenciler nedeniyle notları almak işkence olacaktır.


Bunun için linkteki örnek dosyayı indirin. Tıklayın


"yüklenecek notlar ve formülü" sayfası ÖBS sisteminden indirilen Excel dosyasıdır. Sarı renkli alanlar ise, diğer sayfadan puan çektiğimiz formül alanlarıdır.


"Makineden gelen notlar" sayfası optik okuyucunun size verdiği klasik Excel sayfasıdır. Sarı renkli alanları "Makine notlarının kopyası" alanına kopyaladık. Optik okuyucunun verdiği dosyada isim ve numara tek sütundadır. Bu sorunu aşalım.


"Makine notlarının kopyası" sayfasına gelin. İsim-no tek sütunu seçin, metni sütunlara dönüştürü seçin, sabit genişlik ayarlayın (aşağıdaki resim) ve numara - isim iki sütun olmasını sağlayın.


Numara - isim iki sütuna ayırma

"yüklenecek notlar ve formülü" sayfasına "Makine notlarının kopyası" sayfasından otomatik not çekmek:

Önce: "Makine notlarının kopyası" sayfasına kolaylık sağlasın diye ismin yanındaki sütuna notları kopyaladım (yan yana dursun diye)

- "yüklenecek notlar ve formülü sayfasına gelin
- "E2" hücresine şu formülü yazın  =DÜŞEYARA(B2;'Makine notlarının kopyası'!B1:D159;3;YANLIŞ) yazın, enterleyin. Puanı otomatik çekecek. Fare ile aşağı çekerek hepsini otomatik bulun.

Formül şöyle çalışıyor:
B2 (yani numara) olan hücreyi 'Makine notlarının kopyası' sayfasında "B1:D159" arasında ara, bulunca 3. sütundaki bilgiyi al. Yanlış, tam bilgiyi içermesini istediğimizi belirtiyor.
Not: 'Makine notlarının kopyası'!B1:D159 ifadesini yazmak kolay değil, bunun yerine fare ile notların bulunduğu yerleri seçersek formül oluşur. B,C,D sütunları seçtik, seçtiğimizin 3. sütunundaki değeri istedik.

Dikkat edin: =DÜŞEYARA(B2;  sonra seçilecek alan tüm sütunu içermemeli, sadece veri olan kısmı içermeli, hata verir.

G2 hücresine şunu yazınca NUMARA SAĞLAMASI yaparsınız:
=DÜŞEYARA(B2;'Makine notlarının kopyası'!B1:D159;1;YANLIŞ)

H2 hücresine şunu yazınca İSİM SAĞLAMASI yaparsınız:
=DÜŞEYARA(B2;'Makine notlarının kopyası'!B1:D159;2;YANLIŞ)

"yüklenecek notlar ve formülü" sayfasındaki sarı renkli alanlar, formülle çekilen sonuçları gösteriyor.
Otomatik çekilen not ve formülü görülmektedir


Hiç yorum yok:

Yorum Gönderme

Yorumunuz için teşekkür ederim. Yorumunuz güvenli şekilde elimize ulaştı.
Dr. Metin Çiriş